Updating Plex Media Server again

About one month ago I took the giant leap to the then most recent version of Plex, after running an ancient pre-1.x-version for years, so an upgrade now after only about one month feels really rushed.

But the fixlist seemed worth it, in particular fixes concerning performance and network where I’ve been seeing some glitches after last upgrade. Nothing major, or big enough to require a rollback, but sometimes annoying, so I’m hoping for this being better now, and at least from first glance on the webpage it loads considerably faster now, but I’ll reserve some final judgements until I’ve had some time to watch any movie.

Apart from faster performance on the web I also notice the background is lighter, I liked the old dark background very much but this one is not bad at all actually. I can like this.

What I don’t like so far, and still, is that I can’t disable warnings or alerts in the settings menu for this being a private server and not reachable from internet. It’s supposed to be, it has nothing to do on the internet, could I please turn the alert off? And also at the same time the alert for a new version being available for manual installation, I don’t want that either since I quite prefer to wait for the versions to become available via QNAP appstore, so I can be certain they’re tested by QNAP, for my device hardware.

And there are some missing translations as well for the Swedish localisation.

But if those are the only glitches they’re really no problem and hopefully this will be a great update. New version is 1.5.3.3580.

 

Upgrading Plex Media Server

Today I made a new attempt to upgrade my Plex Media Server on my QNAP to the most recent version available in the QNAP appstore.

From an initial quick check most things seems to have worked better this time, compared to what went wrong the last time.

  • New version prompt is still there, but it’s a minor annoyance only. (And I won’t try the available direct manual download just yet, but stick with the officially available version from QNAP).
  • The unclaimed server prompt still pops up every now and then, also somewhat annoying, still nothing major.
  • I’m not yet used to the new menus, and the front page is in English despite settings being set to Swedish, while the rest of the menus seems to be Swedish. I can’t quite put my finger on it but something feels like missing in the settings menus, but since I can’t spot it right away I’ll assume it’s no problem, for now.
  • Lastly, what broke it last time was that Media Libraries seems corrupt or content missing, no trace of this in this upgrade, so hopefully everything should be fine.

There was a small new surprise in that when trying to change the title of “Recently added movies” to Swedish, this did not change, but also (and instead) added a conversion task of all recent items, which I have no use for and needed to cancel.

It’s also annoying the settings menu can’t be hidden from the left side navigation bar, since it’s anyway present in top right menu, and in navigation bar it shows an error for not being logged in. I wish I could at least disable the warning, if not the entire menu from showing up in navigation.

But all things considered, it feels like the glitches are minor and I can live with them, which is quite nice since I’ll then be past the 1.x version, going from version 0.9.12.18 to version 1.3.4.3285 in one single upgrade. A version jump of 6 major releases and an uncounted minor versions.

I’ll try this on for a few days before claiming it a success though.

Failed upgrade of Plex Media Server

I failed in my attempts to upgrade Plex Media Server on QNAP.

Since I’ve been running on a quite old version 0.9.12.18, for some time, the news that a version 1.x was out felt very interesting.

But, while the upgrade itself worked properly, the problems was what did not work afterwards.

  • Immediately after upgrade I am faced with a message saying there’s a never version, that’s fine since QNAP probably hasn’t certified it yet, but it’s annoying since I had turned off notifications and checks for updated versions in my previous existing installation.
  • More annoying was the repeated message every time I access Plex homepage that there was an unclaimed media server on my network. And I found no way of dismissing the message.
  • The next glitch was all the new (old) menu items were back, and for some reason the menu options for what to show in the sidebar panel, which could be access in the previous version, were now not present.
  • And the final straw that together with everything else above made me revert to the old version, was that once I actually access my different media libraries, a lot of images were missing or broken, and updating the items didn’t seem to work, at least not the first few times.

So now I’m back at version 0.9.12.18 again. I expect there will be quite some time before I attempt another upgrade. Alas. Having a version 1.x would have been nice, but I do prefer the reliability I have had for some years in the older version.

Upgrade of QNAP firmware

I just upgraded to the latest QNAP firmware. Everything seems to be working, but despite the promised patch of Safari-related problems some glitches still remain.

First of all the bug in Plex media server remains, in that it won’t start after first boot after firmware upgrade, but needs a second reboot of the NAS. I’m not sure if this is fixed in the more recent Plex upgrades, since my last attempt to upgrade Plex just caused more problems than it solved and I then chose to downgrade. So, as long as nothing more than a scone reboot is needed I will live with it.

Second, while I’m not sure what Safari problems have been resolved, mine still remains, that I can’t log in at all if using Safari on an iPad. Login menu appears, enter user and password, and nothing happens other than the spinning “wait…” screen. But the apps works so it’s also manageable.